Valuable Support Information

Contact Information

Please feel free to contact our support team, or call us between 8AM-5PM UTC-5 or (CDT United States) M-F (631) 606-6151 (Chicago, Illinois)


Software Updates

The 5.6 version of SafeGuard LM was the last of the 5.x series.  If you find that you need to work with 5.6 because of Operating System version restrictions or the need for other platforms like ARM, PPC, Solaris or older developer tools, you may still purchase 5.6.  There is no more support for 5.6, but there haven’t been any issues reported in a long time.

© 2018 Persistent Security, LLC